Основные понятия [17]
Торговые системы,тактики [67]
Форекс начинающим [16]
Разное [37]

Принудительное обновление терминала MetaTrader! Советники перестали работать? Has newer unsupported version, please update your client termi

Добавить в социальные закладки:

Принудительное обновление терминала MetaTrader! Советники перестали работать? Has newer unsupported version, please update your client terminal

Если Вы скачали советник или получили его от программиста, а он не работает? Вам поможет наша статья: Как принудительно обновить свой терминал до последней версии, не дожидаясь обновления от Вашего брокера. 

 

Предисловие

В последнее время компания MetaQuotes нас удивляет в хорошем смысле, появляются новые возможности для торговли на форекс. Новые инструменты в программировании. Новый функционал и увеличивается качество и скорость работы терминала. 

Но у каждой компании есть и свои "удивительные вещи" , которые неудобны рядовому пользователю. 

Представьте: ВЫ скачиваете нового эксперта, в надежде запустить его на своем терминале, а он отказывается у Вас работать. 

При на несении на график - ничего не происходит? Эксперт умер? Нет.....

Достаточно проанализировать Ваши Лог файлы. Кстати, любая проблема с экспертом решается через лог файлы. как делать лог файлы для программиста? Читай нашу статью Log Files MetaTrader

Итак, Вы открываете вкладку Эксперты и видите следующую запись:

'Exp - VirtualTradePad OLLSTARS v42.ex5' has newer unsupported version, please update your client terminal

Что это ? ошибка? неправильная компиляция? 

Все очень просто. Советник был скомпилирован более поздним билдом чем у Вас. Поэтому У Вас он не запустится. Что делать? Достаточно обновить Ваш терминал до последнего официального билда. и Все советники, скомпилированные ранее будут работать. 

 

Процесс принудительного обновления терминала MetaTrader 

В первую очередь ВЫ должны посмотреть какой билд терминала у Вас в данный момент:

После этого зайдите в меню файл - открыть новый счет

В последнем поле ввода имени брокера обязательно введите METAQUOTES

После этого у Вас появится новый сервер демо счета METAQUOTES-DEMO

Вам необходимо выбрать этот сервер и открыть на данном сервере демо счет.

Далее дело времени и скорости вашего интернета. При подключении к счету, терминал проверяет возможность обновиться до последнего билда терминала и начинает загрузку новых файлов 

при этом в журнале терминала будут отображаться такие записи:

  • MD    0    12:29:03.675    LiveUpdate    new terminal build 1241 (IDE: 1241, Tester: 1241) is available
  • RJ    0    12:30:05.056    LiveUpdate    'mt5clw64' downloaded (20813 kb)
  • JL    0    12:30:31.935    LiveUpdate    'mt5clwide64' downloaded (10275 kb)
  • QF    0    12:30:45.168    LiveUpdate    'mt5clwtst64' downloaded (5616 kb)
  • NL    0    12:30:45.448    LiveUpdate    downloaded successfully

После успешной загрузки новой версии терминала Вам предложат перезапустить терминал:

После перезапуска Ваш терминал будет обновлен и все Ваши советники будут работать на новом терминале. 

Примечание

 Не волнуйтесь, если советник был скомпилирован старым терминалом, он будет у Вас работать без обновления. 

Также не стоит беспокоиться, если у Вас есть исходники Ваших советников. При запуске терминала, Все советники в папке Вашего терминала - компилируются текущим билдом и обновление  втаком случае не требуется.

Но! Обновление это всегда хорошо. В обновлении исправлются баги, добавляются новые возможности, поэтому периодически проверяйте новые версии вашего терминала на сервере METAQUOTES-DEMO

Спасибо за прочтение. 

 

 


Получить бесплатно Принудительное обновление терминала MetaTrader! Советники перестали работать? Has newer unsupported version, please update your client termi

Категория: Разное | Добавил: expforex (24.12.2015)
Просмотров: 1435 | Теги: Принудительное, newer, Has, unsupported, перестали, обновление, MetaTrader!, работать?, терминала, советники | Рейтинг: 5.0/1 |
Всего комментариев: 0
Имя *:
Email:
Код *:



WebMoney Яндекс цитирования.